Sample Cisco configuration (config)

service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 ####################
!
no aaa new-model
!
clock timezone EST -5 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
crypto pki token default removal timeout 0
!
!
username iosadmin privilege 15 secret 5 ########################
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
ip address 10.10.10.2 255.255.255.0
ipv6 address 2001:D8:1:1::302/64
ipv6 address 2001:D8:2:2::/64 eui-64
!
interface Ethernet0/1
ip address 10.10.40.2 255.255.255.0
ipv6 address 2001:DB8:40::2/128 eui-64
!
interface Ethernet0/2
description connection to r306
ip address 10.10.41.1 255.255.255.0
ipv6 address 2001:DB8:41::/64 eui-64
!
interface Ethernet0/3
no ip address
shutdown
!
router bgp 2000
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor internal peer-group
neighbor internal remote-as 2000
neighbor ipv6-internal peer-group
neighbor ipv6-internal remote-as 2000
neighbor 10.10.10.1 remote-as 1000
neighbor 10.10.10.1 password 7 03500A280F1C22431F5B4A
neighbor 10.10.40.4 peer-group internal
neighbor 10.10.40.4 password 7 101A583A0C0411045D5679
neighbor 10.10.41.2 peer-group internal
neighbor 10.10.41.2 password 7 005042250D4808095E731F
neighbor 2001:DB8:40::4 peer-group ipv6-internal
neighbor 2001:DB8:41::306 peer-group ipv6-internal
neighbor 2001:DB8:41:0:A8BB:CCFF:FE01:3220 peer-group ipv6-internal
neighbor 2001:DB8:41:0:A8BB:CCFF:FE01:3220 password 7 ###################
!
address-family ipv4
bgp redistribute-internal
redistribute connected
neighbor 10.10.10.1 activate
neighbor 10.10.40.4 activate
neighbor 10.10.41.2 activate
exit-address-family
!
address-family ipv6
redistribute connected
neighbor 2001:DB8:41::306 activate
neighbor 2001:DB8:41:0:A8BB:CCFF:FE01:3220 activate
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
logging esm config
!
!
!
!
!
!
ipv6 access-list FILTER-IN
permit icmp any any
permit tcp any host 2001:D8:1:1::302 eq telnet
permit tcp any any established
control-plane host
!
!
control-plane
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
password 7 ###############
login local
transport input all
!
end



Comments